Intermittent errors impacting Internet Banking

Incident Report for Bank of London

Resolved

This incident has been resolved.
Posted Jun 27, 2024 - 10:00 BST

Investigating

We are currently investigating this issue.
Posted Jun 27, 2024 - 05:00 BST
This incident affected: Online Banking and API.