Payment services outage

Incident Report for Bank of London

Resolved

The issue is resolved, and all the payment services are operational.
Posted Jul 31, 2025 - 11:43 BST

Monitoring

We have identified the issue and deployed a fix. We are seeing recovery in affected systems. We are continuing to monitor for full recovery.
Posted Jul 31, 2025 - 11:25 BST

Investigating

We’re experiencing a service outage with our payment services. Our team is currently working to restore the services. We apologize for any inconvenience. Next update in an hour.
Posted Jul 31, 2025 - 11:03 BST
This incident affected: API, API Sandbox, Faster Payments, BACS Credit, BACS Direct Debits, and CHAPS.